End of iOS 3.x support

I promised to keep supporting iOS 3.x users as long as I could. The time has finally arrived where there are compelling enough technologies in newer versions that I can’t support 3.x users anymore.   The new minimum requirement will be ios4 and that should include everything but the original iPhone.